Administración Electrónica ¿fácil?

Ayudándote a conseguirlo

Una nueva pesadilla: Firefox 42 no funciona bien con Java

El pasado 3 de noviembre de 2015 salió la nueva actualización del navegador Mozilla Firefox (versión 42). esta versión NO funciona correctamente con Java por lo que con esta versión del navegador no se puede hacer uso de los servicios de administración electrónica que usen applets, que son la mayoría actualmente en toda España.

Esto significa en la práctica que a día de hoy si usamos un ordenador con Windows las posibilidades que tenemos para usar servicios que usen el certificado digital (como las sedes electrónicas) son las siguientes:

  • Usar Internet Explorer
  • Instalar la versión 41 de Firefox ( y configurar el navegador para que no se actualice solo)
  • Instalar la versión 38 de Firefox ESR tal como se explica en el siguiente video:


 

https://www.mozilla.org/en-US/firefox/organizations/all/

¡Recuerden hacer previamente una copia de seguridad del certificado digital para instalarla en el navegador que vayan a usar!

MUCHA PACIENCIA

Más información sobre el problema en:

https://bugzilla.mozilla.org/show_bug.cgi?id=1221448
https://bugzilla.mozilla.org/show_bug.cgi?id=1222036

Anuncios

6 comentarios el “Una nueva pesadilla: Firefox 42 no funciona bien con Java

  1. Josean
    18 enero, 2016

    Hola!

    yo me he visto con el problema, y ademas, en Windows 10 no funciona bien el instalador del dnie, al menos en mi pc.

    pero se me ha ocurrido copiar las dll’s DNIe_P11_pub.dll y DNIe_P11_priv.dll de una instalación en W7 x64, y cargando esas dlls en dispositivos de seguridad, del Firefox 43.0.4, y FUNCIONA!

    Un saludo

    Me gusta

    • asdelacruz
      18 enero, 2016

      Realmente en las últimas versiones de Firefox estándar el problema surge sobre todo si tenemos protegido nuestro certificado didgital con la contraseña maestra de Firefox. En general, al menos por ahora, parece funcionar mejor la versión de Firefox ESR según mi experiencia. Se puede descargar desde:

      https://www.mozilla.org/en-US/firefox/organizations/all/

      Me gusta

      • Josean
        18 enero, 2016

        yo he conseguido que funcionase en la normal, no en la ESR… pero ¿hasta cuando? A ver si los del DNIe arreglan el instalador para windows 10, al menos a mi no me acaba de instalar…

        Me gusta

      • Josean
        19 enero, 2016

        y hoy vuelvo a probar, lo que ayer funcionaba, y ya no funciona… arrrggghhhh 😦

        Me gusta

  2. Josean
    19 enero, 2016

    menos mal que tengo un pantallazo que le saqué, que si funcionaba…

    alguna previsión que Mozilla solucione los problemas con java?

    Me gusta

    • asdelacruz
      19 enero, 2016

      No creo. La cosa va a ir a peor, no a mejor. La tendencia es a intentar eliminar el uso de java en lo que ya se está trabajando desde el Ministerio. En cualquier caso te recomiendo que por ahora te pases a la versión de Firefox ESR

      Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Información

Esta entrada fue publicada en 12 noviembre, 2015 por en Java, Navegadores y etiquetada con .
A %d blogueros les gusta esto: